GPOS lookups stop working when using GSUB lookups

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

GPOS lookups stop working when using GSUB lookups

Piotr Łukaszkiewicz
Hello,

It is a first time I am using a mailing list. I hope I do this correctly. :)

I am quite new to FontForge (or font designing software in general), so perhaps this problem is trivial. The thing is: after adding some GSUB lookups to my font, all of my painstakingly designed kerning stops working. While testing the generated otf file the substitutions work as intended, but the positioning is gone. When I go back to FontForge, remove any GSUB lookups and generate a new file, kerning works fine. 

I find this quite baffling. I thought it normal for most fonts to use both kerning AND ligatures. ;)

Can anyone help me with this?

Regards
-- 
Piotr Łukaszkiewicz

697 254 964

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
fontforge-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/fontforge-users
http://fontforge.10959.n7.nabble.com/User-f8781.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GPOS lookups stop working when using GSUB lookups

JanekZ
Piotr,
Please make the .fea file and make it available for us.
(what ff version?)
Loading...