Fontforge Python on OS X Mavericks 10.9

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fontforge Python on OS X Mavericks 10.9

Dimitre Lima
Hello I'm trying to install fontforge python in OS X Mavericks with no success.
When compiling from source it complains about Python, even with different versions installed, I've reinstalled it throught homebrew too.

No package 'python-2.7' found

And Brew version from git complains of autogen.sh (which now is bootstrap right?)
brew install fontforge --enable-pyextension --HEAD --debug

Failed to execute: ./autogen.sh
/usr/local/Library/Homebrew/formula.rb:573:in `block in system'

And the brew version 20120731_1 is the unique that completes installation but don't seem to install pyextension.

Any tip? Thank you.

Dimitre


------------------------------------------------------------------------------
HPCC Systems Open Source Big Data Platform from LexisNexis Risk Solutions
Find What Matters Most in Your Big Data with HPCC Systems
Open Source. Fast. Scalable. Simple. Ideal for Dirty Data.
Leverages Graph Analysis for Fast Processing & Easy Data Exploration
http://p.sf.net/sfu/hpccsystems
_______________________________________________
Fontforge-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/fontforge-devel
Joe
Reply | Threaded
Open this post in threaded view
|

Re: Fontforge Python on OS X Mavericks 10.9

Joe
On June 20, 2014 01:40:45 PM Dimitre Lima wrote:

> Hello I'm trying to install fontforge python in OS X Mavericks with no
> success. When compiling from source it complains about Python, even
> with different versions installed, I've reinstalled it throught
> homebrew too.
>
> No package 'python-2.7' found
>
> And Brew version from git complains of autogen.sh (which now is
> bootstrap right?) brew install fontforge --enable-pyextension --HEAD
> --debug
>
> Failed to execute: ./autogen.sh
> /usr/local/Library/Homebrew/formula.rb:573:in `block in system'
>
> And the brew version 20120731_1 is the unique that completes
> installation but don't seem to install pyextension.
>
> Any tip? Thank you.

Hi Dimitre,
Install the developer version of python. Our package handler is needing
some improvement to specify you need the developer version because it
requires the python.h include files for building.

Next:
I am not running a Mac, and cannot verrify this, but can you please try the
modification to homebrew's fontforge.rb file explained in
https://github.com/fontforge/fontforge/issues/1366 and see if the solution:

if build.head?
system "sh bootstrap"
else
system "sh autogen.sh"
end
system "./configure", *args

fixes it so it uses ./bootstrap? Details are here:
https://github.com/Homebrew/homebrew/pull/29626


------------------------------------------------------------------------------
HPCC Systems Open Source Big Data Platform from LexisNexis Risk Solutions
Find What Matters Most in Your Big Data with HPCC Systems
Open Source. Fast. Scalable. Simple. Ideal for Dirty Data.
Leverages Graph Analysis for Fast Processing & Easy Data Exploration
http://p.sf.net/sfu/hpccsystems
_______________________________________________
Fontforge-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/fontforge-devel